What’s Vulnerable › Vulnerabilities
CVE-2026-46444: Flowise: Vector Store No Permission Checks
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-08 · updated 2026-07-23
- Weakness: CWE-862
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.1.2, all CRUD endpoints for OpenAI Assistants Vector Store have no authentication middleware and the route path /api/v1/openai-assistants-vector-store is not in WHITELIST_URLS. However, it is also not protected by the main auth middleware when accessed via API key — the route requires API key auth (not whitelisted), but no permission checks exist on any operation. This issue has been patched in version 3.1.2.
Affected products
- FlowiseAI Flowise: before 3.1.2 — fixed in 3.1.2
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.1.2
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-hmg2-jjjx-jcp2
Get alerted when CVE-2026-46444 or the next vulnerability affects your stack