What’s Vulnerable › Vulnerabilities

CVE-2026-46447

Description

OpenStack Ironic before 35.0.2 allows Boot Script Injection of an iPXE script if the attacker can set node.driver_info or node.instance_info.

Affected products

How to fix

Upgrade to a fixed version: OpenStack Ironic 26.1.7, 29.0.6, 32.0.2, 35.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-46447 or the next vulnerability affects your stack