What’s Vulnerable › Vulnerabilities
CVE-2026-46449
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-16
- Weakness: CWE-78
Description
The Akamai Guardicore Platform Agent (GPA) before 7.4 for macOS is affected by a local privilege escalation vulnerability within the wapptunneld component. The vulnerability is caused by a lack of input validation when the service uses network interface names to execute system utilities, resulting in command injection. An unprivileged local user with permissions to modify network interface names can exploit this by renaming a network interface to include a malicious shell payload via System Settings. When the "Log out from your IdP" action is subsequently triggered, the wapptunneld service processes the poisoned interface name, leading to the execution of arbitrary commands with root privileges.
Affected products
- Akamai Guardicore Platform Agent: before 7.4 — fixed in 7.4
How to fix
Upgrade to a fixed version: Akamai Guardicore Platform Agent 7.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-46449 or the next vulnerability affects your stack