What’s Vulnerable › Vulnerabilities

CVE-2026-4646: Insufficient input validation in GitHub plugin API causes denial of service

Description

Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to validate user-supplied input in API request handlers which allows an authenticated attacker to crash the plugin process via a crafted HTTP request to the PR details endpoint.. Mattermost Advisory ID: MMSA-2026-00638

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.15, 11.4.5, 11.5.4, 11.6.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-4646 or the next vulnerability affects your stack