What’s Vulnerable › Vulnerabilities
CVE-2026-46483: Vim: Command injection in tar#Vimuntar via missing shellescape {special} flag
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-15 · updated 2026-06-17
- Weakness: CWE-78
Description
Vim is an open source, command line text editor. Prior to 9.2.0479, a command injection vulnerability exists in tar#Vimuntar() in runtime/autoload/tar.vim when decompressing .tgz archives on Unix-like systems. The function builds :!gunzip and :!gzip -d commands using shellescape(tartail) without the {special} flag, allowing a crafted archive filename to trigger Vim cmdline-special expansion and execute shell commands in the user's context. This vulnerability is fixed in 9.2.0479.
Affected products
- vim/vim: before 9.2.0479 — fixed in 9.2.0479
How to fix
Upgrade to a fixed version: vim/vim 9.2.0479. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/3fb5e58fbc63d86a3e65f1a141b0d67af2aa38a1
- https://github.com/vim/vim/releases/tag/v9.2.0479
- https://github.com/vim/vim/security/advisories/GHSA-2fpv-9ff7-xg5w
Get alerted when CVE-2026-46483 or the next vulnerability affects your stack