What’s Vulnerable › Vulnerabilities
CVE-2026-46485: Dash: Users can write to config despire permissions (OIDC tested)
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-10-24
- Weakness: CWE-15
Description
Dashy is a self-hostable personal dashboard. Prior to 4.0.8, Dashy deployments using OIDC can allow unauthenticated users or non-admin authenticated users to write changes to the main config.yaml through the config-saving functionality despite configured permissions, allowing unauthorized modification of dashboard configuration and potential service disruption. This issue is fixed in version 4.0.8.
Affected products
- lissy93 dashy: before 4.0.8
References
- https://github.com/lissy93/dashy/releases/tag/4.0.8
- https://github.com/lissy93/dashy/security/advisories/GHSA-vjj9-fmvr-6h3p
- https://github.com/lissy93/dashy/security/advisories/GHSA-vjj9-fmvr-6h3p
Get alerted when CVE-2026-46485 or the next vulnerability affects your stack