What’s Vulnerable › Vulnerabilities
CVE-2026-46515: Frogman: Multiple read-tier tools expose admin-grade data and arbitrary GraphQL execution
- Severity: critical (CVSS 9.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-16 · updated 2026-10-24
- Weakness: CWE-862
Description
Frogman provides headless PBX control through MCP and HTTP API. Prior to 1.6.3, PERM_READ access was sufficient to call fm_list_managers, fm_list_pinsets, fm_show_context, fm_get_mcp_config, fm_backup_status, fm_whos_calling, fm_run_saved_query, and fm_diagnose_trunk, exposing AMI manager secrets, outbound dial PINs, full Asterisk dialplan context, root SSH connection commands, backup artifact paths, CDR history, arbitrary saved GraphQL query execution, and raw AMI endpoint dumps containing SIP fields such as password, md5_cred, and oauth_secret. This issue is fixed in version 1.6.3.
Affected products
- mwtcmi frogman: before 1.6.3
References
- https://github.com/mwtcmi/frogman/commit/55ea257d5c24bc01c814a607faa7e76e86b111ec
- https://github.com/mwtcmi/frogman/commit/b8a8bfc12b564bcb77caef952873b9ffd4a98b00
- https://github.com/mwtcmi/frogman/issues/13
- https://github.com/mwtcmi/frogman/issues/25
- https://github.com/mwtcmi/frogman/releases/tag/v1.6.3
- https://github.com/mwtcmi/frogman/security/advisories/GHSA-q4c4-5cr4-8q47
Get alerted when CVE-2026-46515 or the next vulnerability affects your stack