What’s Vulnerable › Vulnerabilities
CVE-2026-46518: OpenEMR: Stored XSS in prescription CSS/HTML print view via patient demographics
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-10 · updated 2026-07-23
- Weakness: CWE-79
Description
OpenEMR is a free and open source electronic health records and medical practice management application. Prior to version 8.0.0.1, a stored cross-site scripting vulnerability in the prescription CSS/HTML multi-print feature allows a patient portal user to execute arbitrary JavaScript in a clinician's browser session. Patient demographic fields (name, address) are rendered without output encoding in multiprintcss_header(), and portal patients can write attacker-controlled HTML directly into patient_data by calling the PUT api/patient/:num endpoint, which bypasses the intended audit review workflow. Because the XSS fires in the clinician's authenticated session on the main OpenEMR interface, the attacker can access CSRF tokens, session data, and perform actions as the clinician — crossing the patient-to-clinician trust boundary. This issue has been patched in version 8.0.0.1.
Affected products
- openemr: before 8.0.0.1 — fixed in 8.0.0.1
How to fix
Upgrade to a fixed version: openemr 8.0.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/security/advisories/GHSA-4gh4-q39r-45wf
- https://github.com/openemr/openemr/security/advisories/GHSA-4gh4-q39r-45wf
Get alerted when CVE-2026-46518 or the next vulnerability affects your stack