What’s Vulnerable › Vulnerabilities
CVE-2026-46557: ImageMagick: Stack overflow in fx operation
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-10 · updated 2026-07-23
- Weakness: CWE-674
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to version 7.1.2-23, due to a missing depth check a stack overflow can occur in the fx operation by passing a crafted argument. This issue has been patched in version 7.1.2-23.
Affected products
- ImageMagick: before 7.1.2-23 — fixed in 7.1.2-23
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-23. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-46557 or the next vulnerability affects your stack