What’s Vulnerable › Vulnerabilities
CVE-2026-46580
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-18 · updated 2026-10-26
- Weakness: CWE-829
Description
In Eclipse Theia versions prior to 1.71.0, files matching the pattern .prompts/*.prompttemplate in a workspace were automatically loaded and could override or extend the AI agent's system prompts. An attacker could craft a malicious repository containing prompt template files that, when the workspace was opened in Theia, replaced the AI's system instructions with attacker-controlled content (indirect prompt injection). Combined with other AI chat features available in untrusted workspaces, this enabled attack chains leading to data exfiltration via Markdown image rendering or arbitrary command execution via task definitions.
Affected products
- Eclipse Foundation Eclipse Theia: before 1.71.0 — fixed in 1.71.0
How to fix
Upgrade to a fixed version: Eclipse Foundation Eclipse Theia 1.71.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-46580 or the next vulnerability affects your stack