What’s Vulnerable › Vulnerabilities
CVE-2026-46605: Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Incomplete authorization during destination removal
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-01 · updated 2026-07-22
- Weakness: CWE-285
Description
Incomplete authorization by Apache ActiveMQ server before versions v6.2.6 and v5.19.7 allows authenticated connections to remove existing destinations with proper permissions. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version v6.2.6 or v5.19.7, which fixes the issue.
Affected products
- Apache ActiveMQ: before 5.19.7; from 6.0.0 before 6.2.6 — fixed in 5.19.7, 6.2.6
- Apache Activemq Broker: before 5.19.7; from 6.0.0 before 6.2.6 — fixed in 5.19.7, 6.2.6
How to fix
Upgrade to a fixed version: Apache ActiveMQ 5.19.7, 6.2.6; Apache Activemq Broker 5.19.7, 6.2.6. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/l4lxgr2s73g9pb218f180psfyskf8ldm
- http://www.openwall.com/lists/oss-security/2026/05/31/20
Get alerted when CVE-2026-46605 or the next vulnerability affects your stack