What’s Vulnerable › Vulnerabilities
CVE-2026-46654: Plonky3 MultiField32Challenger: transcript malleability and challenge entropy loss
- Severity: high (CVSS 8.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-10 · updated 2026-07-23
- Weakness: CWE-345
Description
Plonky3 is a toolkit for polynomial IOPs (PIOPs). Prior to versions 0.4.3 and 0.5.3, an attacker controlling prover-side observations can craft distinct transcripts that produce identical challenges, breaking the binding property of Fiat-Shamir. This issue has been patched in versions 0.4.3 and 0.5.3.
Affected products
- Plonky3: before 0.4.3; from 0.5.0, < 0.5.3
References
Get alerted when CVE-2026-46654 or the next vulnerability affects your stack