What’s Vulnerable › Vulnerabilities
CVE-2026-46697: Fediverse Embeds: Unauthenticated SSRF / open proxy via REST media-proxy endpoint
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-11 · updated 2026-06-17
- Weakness: CWE-918
Description
Fediverse Embeds embeds fediverse posts on WordPress sites. Prior to version 1.5.8, Fediverse Embeds registered an unauthenticated REST route ftf/media-proxy (includes/Media_Proxy.php) with permission_callback => __return_true that accepted a base64-encoded URL and forwarded it to wp_remote_get($url) without enforcing any allowlist. The plugin's source contained a comment block explicitly acknowledging that the request should be validated against allowed fediverse domains, but in 1.5.7 the validation only set a local $can_download_media flag that was never read. The full response body was echoed back to the caller, so this was a full-read SSRF / open proxy reachable by any anonymous visitor. This issue has been patched in version 1.5.8.
Affected products
- stefanbohacek fediverse-embeds-wordpress-plugin: before 1.5.8
References
- https://github.com/stefanbohacek/fediverse-embeds-wordpress-plugin/commit/2f021faf4dadaccef67eda7b81a0b7ceaef450df
- https://github.com/stefanbohacek/fediverse-embeds-wordpress-plugin/security/advisories/GHSA-mpq6-hjh3-m543
Get alerted when CVE-2026-46697 or the next vulnerability affects your stack