What’s Vulnerable › Vulnerabilities
CVE-2026-4671: justhtml before 1.18.0 Denial of Service via CSS Selector
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-23 · updated 2026-10-12
- Weakness: CWE-400
Description
justhtml before 1.18.0 contains multiple low-severity denial-of-service issues in CSS selector handling and linkification. Applications that evaluate attacker-controlled selector strings (via query(), matches(), or selector-based transforms), run selector matching over very large untrusted documents, construct DOM trees from untrusted structure, or enable linkification over attacker-controlled text may consume disproportionate CPU or memory. Triggers include oversized selectors, large selector lists, oversized compound selectors, long combinator chains, deeply nested functional pseudo-classes, repeated token/positional matching, cyclic DOM graphs causing non-terminating traversal, and punctuation-heavy or trailing-bracket linkification input. These are availability-only concerns and do not by themselves allow script execution, data disclosure, or sanitizer bypass. Default JustHTML(sanitize=True) usage is not expected to be exposed, since selectors are normally supplied by application code.
Affected products
- EmilStenstrom justhtml: before 1.18.0 — fixed in 1.18.0
How to fix
Upgrade to a fixed version: EmilStenstrom justhtml 1.18.0. Check the vendor advisory for mitigations.
References
- https://github.com/EmilStenstrom/justhtml/security/advisories/GHSA-r8cj-3554-33mr
- https://www.vulncheck.com/advisories/justhtml-before-denial-of-service-via-css-selector
Get alerted when CVE-2026-4671 or the next vulnerability affects your stack