What’s Vulnerable › Vulnerabilities
CVE-2026-46710: Notepad++: Privilege Escalation in the Installer via Uncontrolled Executable Search Path
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-26 · updated 2026-06-29
- Weakness: CWE-426
Description
Notepad++ is a free and open-source source code editor. From 8.9.4 until 8.9.6, Notepad++ contains a local privilege escalation vulnerability in the installer. During installation, the installer invokes powershell.exe without using an absolute path after setting the working directory to the installation contextMenu directory. If an attacker can pre-place a malicious powershell.exe in a user-writable custom installation directory, and a privileged user later runs the installer and selects that directory, the attacker-controlled executable is launched with the elevated privileges of the installer. This vulnerability is fixed in 8.9.6.
Affected products
- Notepad++: from 8.9.4 before 8.9.6 — fixed in 8.9.6
How to fix
Upgrade to a fixed version: Notepad++ 8.9.6. Check the vendor advisory for mitigations.
References
- https://github.com/notepad-plus-plus/notepad-plus-plus/commit/1d4aabe2102d982667ead2dd974bee5e0b1f2d9c
- https://github.com/notepad-plus-plus/notepad-plus-plus/security/advisories/GHSA-6f8f-vmfc-r8c5
Get alerted when CVE-2026-46710 or the next vulnerability affects your stack