What’s Vulnerable › Vulnerabilities

CVE-2026-46718: Apache Calcite: A user-controled model can load arbitrary classes, leading to code execution

Description

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite. This issue affects Apache Calcite: from 1.5.0 before 1.42. Users are recommended to upgrade to version 1.42, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Calcite 1.42.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-46718 or the next vulnerability affects your stack