What’s Vulnerable › Vulnerabilities
CVE-2026-47102: LiteLLM < 1.83.10 Privilege Escalation via User Update
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-21 · updated 2026-10-08
- Weakness: CWE-863
Description
LiteLLM prior to 1.83.10 allows a user to modify their own user_role via the /user/update endpoint. While the endpoint correctly restricts users to updating only their own account, it does not restrict which fields may be changed. A user who can reach this endpoint can set their role to proxy_admin, gaining full administrative access to LiteLLM including all users, teams, keys, models, and prompt history. Users with the org_admin role have legitimate access to this endpoint and can exploit this vulnerability without chaining any additional flaw.
Affected products
- BerriAI litellm: before 1.83.10 — fixed in 1.83.10
How to fix
Upgrade to a fixed version: BerriAI litellm 1.83.10. Check the vendor advisory for mitigations.
References
- https://gist.github.com/13ph03nix/9ec616e1fdc77b3673509c60206e827f
- https://github.com/BerriAI/litellm/commit/128d32d2494b759c5d15da3452452af4c6a34c01
- https://github.com/BerriAI/litellm/commit/e6f18ce75b111c9b93dc15c72894cbdeb53177ce
- https://github.com/BerriAI/litellm/pull/25541
- https://github.com/BerriAI/litellm/releases/tag/v1.83.10-stable
- https://huntr.com/bounties/8e75edfb-ff05-4e63-bfca-2d93d03fb3b9
- https://www.obsidiansecurity.com/blog/litellm-privilege-escalation-rce
- https://www.vulncheck.com/advisories/litellm-privilege-escalation-via-user-update
- https://access.redhat.com/security/cve/CVE-2026-47102
- https://bugzilla.redhat.com/show_bug.cgi?id=2480634
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-47102.json
Get alerted when CVE-2026-47102 or the next vulnerability affects your stack