What’s Vulnerable › Vulnerabilities
CVE-2026-47107: Windmill < 1.703.2 Incorrect Default Permissions in nsjail Configuration
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-19 · updated 2026-10-06
- Weakness: CWE-276
Description
Windmill prior to 1.703.2 contains an incorrect default permissions vulnerability in nsjail sandbox configuration files where /etc is bind-mounted without read-write restrictions, allowing authenticated users to write arbitrary entries to /etc/hosts, /etc/resolv.conf, and /etc/ssl/certs/ca-certificates.crt from within script execution sandboxes. Attackers can exploit persistent poisoned entries across all subsequent script executions on the same worker pod to redirect hostnames, intercept DNS queries, perform transparent HTTPS man-in-the-middle attacks, and intercept WM_TOKEN JWTs to gain workspace-admin access to other users' workspaces.
Affected products
- windmill-labs windmill: before 1.703.2 — fixed in 1.703.2
How to fix
Upgrade to a fixed version: windmill-labs windmill 1.703.2. Check the vendor advisory for mitigations.
References
- https://github.com/windmill-labs/windmill/commit/f8467f38c8a053117ce62f96684cfb15ef792f08
- https://github.com/windmill-labs/windmill/pull/9194
- https://github.com/windmill-labs/windmill/releases/tag/v1.703.2
- https://www.vulncheck.com/advisories/windmill-incorrect-default-permissions-in-nsjail-configuration
- https://github.com/windmill-labs/windmill/pull/9194
Get alerted when CVE-2026-47107 or the next vulnerability affects your stack