What’s Vulnerable › Vulnerabilities
CVE-2026-47121: Sparkle: Binary delta apply intermediate-symlink traversal in malicious .delta
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-21 · updated 2026-10-24
- Weakness: CWE-22
Description
Sparkle is a software update framework for macOS. Prior to version 2.9.2, `Autoupdate/SUBinaryDeltaApply.m` enforces `relativePath.pathComponents containsObject:@".."` and rejects writes whose immediate parent directory IS itself a symbolic link, but does not detect symlinks deeper in the relative path. `Autoupdate/SPUSparkleDeltaArchive.m`'s `extractItem:` will create symlinks in the destination tree from archive content (no `..` check on the symlink target), and a subsequent `Extract` item targeting `<symlink>/foo/bar` then escapes the destination tree via `fopen(path, "wb")` because the kernel resolves the intermediate symlink during the open call. This is a defense-in-depth issue: exploitation requires a maliciously-crafted `.delta` that passes EdDSA signature verification, i.e. EdDSA private-key compromise. With the AppInstaller running as root for system-domain installs, it gives the holder of a stolen signing key arbitrary file write at root level via the delta-apply path, which is a strictly broader primitive than the "drop-in replacement bundle" install they would otherwise have. Version 2.9.2 contains a patch for the issue.
Affected products
- sparkle-project Sparkle: before 2.9.2 — fixed in 2.9.2
How to fix
Upgrade to a fixed version: sparkle-project Sparkle 2.9.2. Check the vendor advisory for mitigations.
References
- https://github.com/sparkle-project/Sparkle/commit/fe7b718d0736f3e139e374e26fbca96f29e13bf0
- https://github.com/sparkle-project/Sparkle/security/advisories/GHSA-hg88-v3cw-3qrh
- https://github.com/sparkle-project/Sparkle/security/advisories/GHSA-hg88-v3cw-3qrh
Get alerted when CVE-2026-47121 or the next vulnerability affects your stack