What’s Vulnerable › Vulnerabilities
CVE-2026-47138: Parse Server: Pre-authentication denial of service via client version header regex backtracking
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-12 · updated 2026-10-26
- Weakness: CWE-1333
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.77 and 9.9.1-alpha.1, an unauthenticated attacker who knows a publicly-known Parse Application ID can submit a single HTTP request whose client SDK version field contains adversarial input that triggers polynomial backtracking in a request-header parser. The parsing runs before session authentication and before rate limiting on every /parse/* request, so the request consumes seconds to minutes of synchronous CPU on a Node.js worker before any access control evaluates it. A small number of concurrent requests can saturate a worker; a single large request via the body-field variant can pin a worker for minutes. Production deployments running the default configuration are affected. This issue has been patched in versions 8.6.77 and 9.9.1-alpha.1.
Affected products
- parse-community parse-server: before 8.6.77; from 9.0.0, < 9.9.1-alpha.1
References
- https://github.com/parse-community/parse-server/pull/10463
- https://github.com/parse-community/parse-server/pull/10464
- https://github.com/parse-community/parse-server/security/advisories/GHSA-38m6-82c8-4xfm
Get alerted when CVE-2026-47138 or the next vulnerability affects your stack