What’s Vulnerable › Vulnerabilities
CVE-2026-47167: Vim: Vimscript Code Injection in cucumber filetype plugin via crafted step-definition regex
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-11 · updated 2026-06-17
- Weakness: CWE-94
Description
Vim is an open source, command line text editor. Prior to version 9.2.0496, a code injection vulnerability exists in s:stepmatch() in the cucumber filetype plugin (runtime/ftplugin/cucumber.vim) on Vim builds with +ruby support. Step-definition patterns read from .rb files under the repository's features/*/ or stories/*/ directories are embedded into a Ruby Kernel.eval argument without sufficient escaping, allowing a crafted pattern in an attacker-controlled repository to execute arbitrary Ruby (and through it arbitrary shell commands) when the user invokes a step-jump mapping ([d, ]d). This issue has been patched in version 9.2.0496.
Affected products
- vim/vim: before 9.2.0496 — fixed in 9.2.0496
How to fix
Upgrade to a fixed version: vim/vim 9.2.0496. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/a65a52d684bc58535ad28a4ae824d22e76399934
- https://github.com/vim/vim/releases/tag/v9.2.0496
- https://github.com/vim/vim/security/advisories/GHSA-4473-94jm-w5x9
Get alerted when CVE-2026-47167 or the next vulnerability affects your stack