What’s Vulnerable › Vulnerabilities
CVE-2026-47181: PenguinMod-BackendApi: NoSQL Injection in Password Reset Endpoint Allows Account Takeover
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-11 · updated 2026-10-26
- Weakness: CWE-20
Description
PenguinMod-BackendApi is the backend api for penguinmod. Prior to version 1.0.0, a NoSQL injection vulnerability in the password reset endpoint allows any authenticated user to change the password of an account, leading to full account takeover. An attacker only needs a registered account and a valid password reset token for their own account. This issue has been patched in version 1.0.0.
Affected products
- PenguinMod-BackendApi: before 1.0.0
References
- https://github.com/PenguinMod/PenguinMod-BackendApi/security/advisories/GHSA-wwwc-jwrc-3pj8
- https://github.com/PenguinMod/PenguinMod-BackendApi/security/advisories/GHSA-wwwc-jwrc-3pj8
Get alerted when CVE-2026-47181 or the next vulnerability affects your stack