What’s Vulnerable › Vulnerabilities
CVE-2026-47216: Typesense: Unauthenticated Denial of Service in the Typesense /multi_search Endpoint
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-12 · updated 2026-06-17
- Weakness: CWE-754
Description
Typesense is a fast, typo-tolerant search engine. Prior to versions 29.1 and 30.2, there is an unauthenticated denial-of-service vulnerability in the /multi_search endpoint. A specially crafted request can trigger an unhandled exception during request processing, causing the server process to terminate. This issue can be exploited over the network without authentication and results in service unavailability. The duration of impact may vary depending on system configuration and dataset size. This issue has been patched in versions 29.1 and 30.2.
Affected products
- typesense: before 29.1; from 30.0, < 30.2
References
Get alerted when CVE-2026-47216 or the next vulnerability affects your stack