What’s Vulnerable › Vulnerabilities

CVE-2026-47262: containerd image-triggered runtime DoS via unbounded group parsing

Description

containerd is an open-source container runtime. Versions prior to 1.7.33, 2.0.10, 2.1.9, 2.2.5 and 2.3.2, contain a vulnerability that allows a maliciously crafted image to cause a Denial of Service (DoS) condition. When creating a container from this image, memory exhaustion occurs, leading to an Out Of Memory (OOM) kill of the containerd process. This renders the container runtime API unavailable and can disrupt clients such as the Docker Engine or Kubernetes control-plane components. This issue has been fixed in versions 1.7.33, 2.0.10, 2.1.9, 2.2.5 and 2.3.2.

Affected products

How to fix

Upgrade to a fixed version: containerd 1.7.33, 2.0.10, 2.1.9, 2.2.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-47262 or the next vulnerability affects your stack