What’s Vulnerable › Vulnerabilities
CVE-2026-47273: pam_usb: XPath injection via PAM-supplied identifiers in pam_usb configuration queries
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-10-26
- Weakness: CWE-91
Description
pam_usb provides hardware authentication for Linux using ordinary removable media. Prior to 0.9.0, pam_usb builds XPath expressions from user-supplied identifiers (PAM username, service name) and device-supplied identifiers (USB device serial, model, vendor) to query /etc/pamusb.conf. These identifiers were not validated for XPath metacharacters, allowing injection of arbitrary XPath predicates. This vulnerability is fixed in 0.9.0.
Affected products
- mcdope pam_usb: before 0.9.0
References
- https://github.com/mcdope/pam_usb/commit/721fed08a3596cb5b4671ad702f8fdc12dcc7420
- https://github.com/mcdope/pam_usb/pull/311
- https://github.com/mcdope/pam_usb/security/advisories/GHSA-vfj3-5h5v-6g93
Get alerted when CVE-2026-47273 or the next vulnerability affects your stack