What’s Vulnerable › Vulnerabilities

CVE-2026-47339: Apache APISIX: authz-casdoor incorrect session sharing

Description

Incorrect Authorization vulnerability in Apache APISIX. An attacker can capitalise on authz-casdoor plugin under default configuration to authenticate themselves with credentials from a different source. This issue affects Apache APISIX: from 2.14.1 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache APISIX 3.17.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-47339 or the next vulnerability affects your stack