What’s Vulnerable › Vulnerabilities
CVE-2026-47424: OpenAM Authenticated RCE via Groovy Sandbox Escape
- Severity: high (CVSS 7.5 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-23
- Weakness: CWE-693
Description
Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, GroovySandboxValueFilter permits an authenticated server-side script author to escape the scripting sandbox despite the default class allow and deny lists. A user such as a sub-realm RealmAdmin who can create or edit a script in an executed context can invoke operating-system commands as the OpenAM application server account, crossing the realm-scoped administration boundary and compromising the JVM and every realm it serves. This issue is fixed in version 16.1.1.
Affected products
- OpenIdentityPlatform OpenAM: before 16.1.1
References
- https://github.com/OpenIdentityPlatform/OpenAM/commit/5c843cc7d5d89d908a2222bf3693754f94811599
- https://github.com/OpenIdentityPlatform/OpenAM/releases/tag/16.1.1
- https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-69j4-qvqr-hpw3
Get alerted when CVE-2026-47424 or the next vulnerability affects your stack