What’s Vulnerable › Vulnerabilities

CVE-2026-47759: TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes

Description

TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability via unsanitized data-mce-* attributes (data-mce-href, data-mce-src, data-mce-style). Allows attackers to inject malicious values that override safe attributes during serialization, bypassing validation. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.

Affected products

How to fix

Upgrade to a fixed version: tinymce 5.11.1, 7.9.3, 8.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-47759 or the next vulnerability affects your stack