What’s Vulnerable › Vulnerabilities
CVE-2026-47760: TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-28 · updated 2026-10-14
- Weakness: CWE-79
Description
TinyMCE is an open source rich text editor. From 6.8.0 to before 7.1.0, TinyMCE contains an XSS vulnerability caused by improper SVG namespace scope handling in the sanitizer. A crafted payload using nested elements can bypass attribute sanitization and execute arbitrary JavaScript. This vulnerability is fixed in 7.1.0.
Affected products
- tinymce: from 6.8.0 before 7.1.0 — fixed in 7.1.0
How to fix
Upgrade to a fixed version: tinymce 7.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-47760 or the next vulnerability affects your stack