What’s Vulnerable › Vulnerabilities

CVE-2026-47761: TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection

Description

TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via crafted data-mce-* attributes, which are executed when content is rendered. Impacts users of TinyMCE with the media plugin enabled. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.

Affected products

How to fix

Upgrade to a fixed version: tinymce 5.11.1, 7.9.3, 8.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-47761 or the next vulnerability affects your stack