What’s Vulnerable › Vulnerabilities

CVE-2026-47762: TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments

Description

TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability via forged mce:protected comments. Allows attackers to bypass sanitization and inject scripts that execute when content is restored. Impacts users who utilize the protect option. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.

Affected products

How to fix

Upgrade to a fixed version: tinymce 5.11.1, 7.9.3, 8.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-47762 or the next vulnerability affects your stack