What’s Vulnerable › Vulnerabilities
CVE-2026-47774: Envoy vulnerable to HTTP/2 memory exhaustion via cookie header size bypass and HPACK amplification
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-17 · updated 2026-10-26
- Weakness: CWE-405
Description
Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.35.11, 1.36.7, 1.37.3, and 1.38.1, a vulnerability in Envoy's HTTP/2 downstream request processing allows an unauthenticated remote client to trigger excessive memory consumption, potentially resulting in OOM termination of the Envoy process and denial of service. The issue arises from the combination of two behaviors. First, cookie header bytes are not fully accounted for during request header size validation in Envoy. Second, HPACK header block limits in oghttp2/quiche are enforced on encoded bytes without a corresponding limit on total decoded header size. Together, these behaviors allow a malicious client to cause large decoded header allocations while bypassing the intended request header size protections. Versions 1.35.11, 1.36.7, 1.37.3, and 1.38.1 contain a fix. No complete workaround is known short of applying a fix. Possible temporary mitigations include disabling downstream HTTP/2 where operationally feasible; enforcing stricter request header and cookie limits before traffic reaches Envoy; and monitoring Envoy memory usage for abnormal growth under HTTP/2 traffic.
Affected products
- envoyproxy envoy: before 1.35.11; from 1.36.0 before 1.36.7; from 1.37.0 before 1.37.3; 1.38.0 — fixed in 1.35.11, 1.36.7, 1.37.3
- Red Hat OpenShift Service Mesh 2: from 2.6 before 2.6.17; from 3.0 before 3.0.12; from 3.1 before 3.1.9; from 3.2 before 3.2.6; from 3.3 before 3.3.4 — fixed in 2.6.17, 3.0.12, 3.1.9, 3.2.6, 3.3.4
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.35.11, 1.36.7, 1.37.3; Red Hat OpenShift Service Mesh 2 2.6.17, 3.0.12, 3.1.9, 3.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-22m2-hvr2-xqc8
- http://www.openwall.com/lists/oss-security/2026/06/04/15
- https://access.redhat.com/errata/RHSA-2026:26210
- https://access.redhat.com/errata/RHSA-2026:26222
- https://access.redhat.com/errata/RHSA-2026:26231
- https://access.redhat.com/errata/RHSA-2026:26247
- https://access.redhat.com/errata/RHSA-2026:27114
- https://access.redhat.com/security/cve/CVE-2026-47774
- https://bugzilla.redhat.com/show_bug.cgi?id=2487465
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-47774.json
Get alerted when CVE-2026-47774 or the next vulnerability affects your stack