What’s Vulnerable › Vulnerabilities
CVE-2026-47781: pdm: Project-Controlled `.pdm-plugins` Content Executes Before CLI Parsing
- Severity: high (CVSS 8.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-04 · updated 2026-10-24
- Weakness: CWE-94
Description
PDM is a Python package and dependency manager. In versions up to and including 2.26.9, PDM automatically loads project-local plugins from a .pdm-plugins directory during initialization, allowing an attacker-controlled file in an untrusted repository checkout to execute arbitrary Python code before any command is parsed. This happens because load_plugins() runs during Core.init() and adds .pdm-plugins via site.addsitedir(), which processes .pth files and immediately executes any line beginning with import, so the code runs with the privileges of the user invoking pdm and even a benign command such as pdm --version triggers it (making the impact strongest in CI, automation, and privileged contexts). The issue is fixed in version 2.27.0.
Affected products
- pdm-project pdm: before 2.27.0
References
- https://github.com/pdm-project/pdm/releases/tag/2.27.0
- https://github.com/pdm-project/pdm/security/advisories/GHSA-qq6c-99pv-prvf
- https://github.com/pdm-project/pdm/security/advisories/GHSA-qq6c-99pv-prvf
Get alerted when CVE-2026-47781 or the next vulnerability affects your stack