What’s Vulnerable › Vulnerabilities
CVE-2026-47786: Pre-Authentication Command Injection
- Severity: critical (CVSS 9.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-15 · updated 2026-10-15
- Weakness: CWE-78
Description
An OS command injection vulnerability has been reported to affect HybridDesk Station. If exploited, the vulnerability could allow remote attackers to execute arbitrary commands. We have already fixed the vulnerability in the following version: HybridDesk Station 4.2.23 and later HybridDesk Station 4.3.4 and later
Affected products
- QNAP Systems Inc. HybridDesk Station: from 4.2.x before 4.2.23; from 4.3.x before 4.3.4 — fixed in 4.2.23, 4.3.4
How to fix
Upgrade to a fixed version: QNAP Systems Inc. HybridDesk Station 4.2.23, 4.3.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-47786 or the next vulnerability affects your stack