What’s Vulnerable › Vulnerabilities
CVE-2026-47790: Privilege Escalation via QuFTP Log-based XSS
- Severity: medium (CVSS 6.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-15 · updated 2026-10-15
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability has been reported to affect QuFTP Service. If a remote attacker gains a user account, they can then exploit the vulnerability to inject malicious code. We have already fixed the vulnerability in the following version: QuFTP Service 1.4.6 and later QuFTP Service 1.5.5 and later QuFTP Service 1.6.5 and later
Affected products
- QNAP Systems Inc. QuFTP Service: from 1.4.x before 1.4.6; from 1.5.x before 1.5.5; from 1.6.x before 1.6.5 — fixed in 1.4.6, 1.5.5, 1.6.5
How to fix
Upgrade to a fixed version: QNAP Systems Inc. QuFTP Service 1.4.6, 1.5.5, 1.6.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-47790 or the next vulnerability affects your stack