What’s Vulnerable › Vulnerabilities
CVE-2026-47827: CVE-2026-47827 – BOSH CLI Powershell Injection
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-21 · updated 2026-10-16
- Weakness: CWE-77
Description
Command Injection in BOSH CLI tool on windows in Cloud Foundry allows a remote attacker to execute arbitrary shell commands via command injection vulnerabilities
Affected products
- Cloud Foundry Foundation BOSH CLI: before 2.840.0 — fixed in 2.840.0
How to fix
Upgrade to a fixed version: Cloud Foundry Foundation BOSH CLI 2.840.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-47827 or the next vulnerability affects your stack