What’s Vulnerable › Vulnerabilities
CVE-2026-47877: Spring Security Authorization Server Default Consent Page is vulnerable to Cross-Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-27 · updated 2026-09-02
- Weakness: CWE-79
Description
Spring Security Authorization Server's default consent page renders user-controlled values without HTML entity encoding. Spring Security 7.1.0 Spring Security 7.0.0 - 7.0.6
Affected products
- Spring Security: from 7.0.0 before 7.0.6.1; from 7.1.0 before 7.1.0.1 — fixed in 7.0.6.1, 7.1.0.1
- Spring Security: from 7.0.0 through 7.0.6; 7.1.0
How to fix
Upgrade to a fixed version: Spring Security 7.0.6.1, 7.1.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-47877 or the next vulnerability affects your stack