What’s Vulnerable › Vulnerabilities

CVE-2026-47886: Spring Framework Denial of Service via Unbounded Exponentiation in SpEL Expressions

Description

Applications that evaluate user-supplied Spring Expression Language (SpEL) expressions may be vulnerable to a Denial of Service (DoS) attack when the power operator (^) is used with a BigDecimal or BigInteger operand and a large exponent value. Spring Framework 7.0.0 - 7.0.8 Spring Framework 6.2.0 - 6.2.19 Spring Framework 6.1.0 - 6.1.28 Spring Framework 6.0.0 - 6.0.30 Spring Framework 5.3.0 - 5.3.49 Spring Framework 5.2.25.RELEASE and earlier

Affected products

How to fix

Upgrade to a fixed version: Spring Framework 5.2.26, 5.3.50, 6.0.31, 6.1.29. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-47886 or the next vulnerability affects your stack