What’s Vulnerable › Vulnerabilities
CVE-2026-47907: Dreamweaver Desktop | Improper Access Control (CWE-284)
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-08-28
- Weakness: CWE-284
Description
Dreamweaver Desktop versions 21.7 and earlier are affected by an Improper Access Control vulnerability that could result in arbitrary code execution in the context of the current user. An attacker could exploit this vulnerability to execute arbitrary code. Exploitation of this issue requires user interaction in that a victim must open a malicious file. Scope is changed.
Affected products
- Adobe Dreamweaver Desktop: before 21.8 — fixed in 21.8
How to fix
Upgrade to a fixed version: Adobe Dreamweaver Desktop 21.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-47907 or the next vulnerability affects your stack