What’s Vulnerable › Vulnerabilities
CVE-2026-47909: Dreamweaver Desktop | Improper Input Validation (CWE-20)
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-08-28
- Weakness: CWE-20
Description
Dreamweaver Desktop versions 21.7 and earlier are affected by an Improper Input Validation vulnerability that could lead to arbitrary file system read. An attacker could exploit this vulnerability to access sensitive files and directories outside the intended access scope. Exploitation of this issue requires user interaction in that a victim must open a malicious file. Scope is changed.
Affected products
- Adobe Dreamweaver Desktop: before 21.8 — fixed in 21.8
How to fix
Upgrade to a fixed version: Adobe Dreamweaver Desktop 21.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-47909 or the next vulnerability affects your stack