What’s Vulnerable › Vulnerabilities
CVE-2026-4794: Multiple cross-site scripting (XSS) vulnerabilities in PaperCut NG/MF
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple cross-site scripting (XSS) vulnerabilities in PaperCut NG/MF before 25.0.10 allow authenticated administrator users to inject arbitrary web script or HTML code via different UI fields. This could be used to compromise other admininistrator's sessions or perform unauthorized actions via the administrator's authenticated context (e.g. requires an active login session).
Affected products
- PaperCut MF: before 25.0.10 — fixed in 25.0.10
- PaperCut NG: before 25.0.10 — fixed in 25.0.10
How to fix
Upgrade to a fixed version: PaperCut MF 25.0.10; PaperCut NG 25.0.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-4794 or the next vulnerability affects your stack