What’s Vulnerable › Vulnerabilities
CVE-2026-48032: Hulumi: IAM-role policy checks bypassed when the role trusts multiple OIDC providers
- Severity: high (CVSS 8.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-24 · updated 2026-10-24
- Weakness: CWE-697
Description
Hulumi is an open-source toolkit that ships secure-by-default cloud and platform infrastructure components for Pulumi. Prior to version 1.4.0, IAM-role policy checks can be bypassed when the role trusts multiple OIDC providers. This issue has been patched in version 1.4.0.
Affected products
- kerberosmansour hulumi: before 1.4.0
References
- https://github.com/kerberosmansour/hulumi/pull/178
- https://github.com/kerberosmansour/hulumi/releases/tag/v1.4.0
- https://github.com/kerberosmansour/hulumi/security/advisories/GHSA-g759-4pxw-6692
Get alerted when CVE-2026-48032 or the next vulnerability affects your stack