What’s Vulnerable › Vulnerabilities
CVE-2026-48042: Envoy: Stack overflow in destructor of highly nested JSON
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-26 · updated 2026-10-25
- Weakness: CWE-1124
Description
Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to 1.35.11, 1.36.7, 1.37.3, and 1.38.1, destructor of JSON Object results in stack overflow when deeply O(100K) nested objects are present. This vulnerability is fixed in 1.35.11, 1.36.7, 1.37.3, and 1.38.1.
Affected products
- envoyproxy envoy: from 1.18.0 before 1.35.13; from 1.36.0 before 1.36.9; from 1.37.0 before 1.37.5; from 1.38.0 before 1.38.3 — fixed in 1.35.13, 1.36.9, 1.37.5, 1.38.3
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.35.13, 1.36.9, 1.37.5, 1.38.3. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/blob/099a9d71ebfd8aa9f823e1738b34138cb634a07b/source/common/json/json_loader.h#L21
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-f24p-rxw2-g6pv
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-f24p-rxw2-g6pv
Get alerted when CVE-2026-48042 or the next vulnerability affects your stack