What’s Vulnerable › Vulnerabilities
CVE-2026-48044: Envoy Zstd Decompressor: Ratio Check at Wrong Loop Depth lead to memory explosion
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-26 · updated 2026-10-25
- Weakness: CWE-409
Description
Envoy is an open source edge and service proxy designed for cloud-native applications. From 1.23.0 until 1.35.11, 1.36.7, 1.37.3, and 1.38.1, a vulnerability has been identified in Envoy's zstd decompressor implementation (ZstdDecompressorImpl). When zstd decompression is enabled, processing a specially crafted, highly compressed zstd payload can lead to massive memory allocation. An attacker can exploit this to cause severe memory exhaustion, potentially resulting in an Out-Of-Memory (OOM) kill and Denial of Service (DoS) for the Envoy proxy. This vulnerability is fixed in 1.35.11, 1.36.7, 1.37.3, and 1.38.1.
Affected products
- envoyproxy envoy: from 1.23.0 before 1.35.13; from 1.36.0 before 1.36.9; from 1.37.0 before 1.37.5; from 1.38.0 before 1.38.3 — fixed in 1.35.13, 1.36.9, 1.37.5, 1.38.3
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.35.13, 1.36.9, 1.37.5, 1.38.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-48044 or the next vulnerability affects your stack