What’s Vulnerable › Vulnerabilities
CVE-2026-48138: Out-of-bounds read vulnerability in the NI grpc-device streaming API
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-19 · updated 2026-06-25
- Weakness: CWE-125
Description
There is an out-of-bounds read vulnerability in the NI grpc-device streaming API due to a missing bounds check that may result in a denial of service. Successful exploitation requires an attacker to supply a specially crafted write request. This affects NI grpc-device 2.17.0 and prior versions.
Affected products
- NI InstrumentStudio: through 2025; 2026-q1, 2026-q2
- Ni Grpc Device Server: before 2.18.0 — fixed in 2.18.0
How to fix
Upgrade to a fixed version: Ni Grpc Device Server 2.18.0. Check the vendor advisory for mitigations.
References
- https://github.com/ni/grpc-device/security/advisories/GHSA-8rjh-429j-f6gw
- https://www.ni.com/en/support/security/available-critical-and-security-updates-for-ni-software/2026/multiple-vulnerabilities-in-ni-grpc-device-server.html
Get alerted when CVE-2026-48138 or the next vulnerability affects your stack