What’s Vulnerable › Vulnerabilities
CVE-2026-48142: NGINX ngx_http_charset_module vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-17 · updated 2026-08-11
- Weakness: CWE-125
Description
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_charset_module module. When content is served or proxied through a location block with both source_charset utf-8; and a charset directive (for example, charset koi8-r;) configured, remote, unauthenticated attackers can send requests (in conjunction with conditions beyond their control) to cause a heap buffer over-read in the NGINX worker process, leading to limited disclosure of memory or a restart. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 Dos: from 4.3.0 through 4.7.0; 4.9.0
- F5 NGINX Gateway Fabric: from 1.3.0 through 1.6.2; from 2.0.0 through 2.6.3
- F5 NGINX Ingress Controller: from 3.5.0 through 3.7.2; from 4.0.0 through 4.0.1; from 5.0.0 through 5.5.0
- F5 NGINX Instance Manager: from 2.17.0 through 2.22.0
- F5 NGINX Open Source: from 1.0.0 through 1.30.2; from 1.31.0 through 1.31.1
- F5 NGINX Plus: from 37.0.0.1 before 37.0.2.1; from r33 before r36; r36, r36-p1, r36-p2, r36-p3, r36-p4, r36-p5 — fixed in 37.0.2.1, r36
- F5 Waf: from 4.10.0 through 4.16.0; from 5.2.0 through 5.8.0; from 5.9.0 through 5.13.1
How to fix
Upgrade to a fixed version: F5 NGINX Plus 37.0.2.1, r36. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-48142 or the next vulnerability affects your stack