What’s Vulnerable › Vulnerabilities

CVE-2026-48165: MariaDB: unsafe usage of `wsrep_sst_receive_address` values on the joiner side

Description

MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.27, 10.11.1 to before 10.11.18, 11.4.1 to before 11.4.12, 11.8.1 to before 11.8.8, and 12.3.1, a high-privileged MariaDB user could've used wsrep_sst_receive_address or wsrep_sst_donor global system variables to execute shell commands as the uid of the mariadbd process on the galera joiner node. This issue has been patched in versions 10.6.27, 10.11.18, 11.4.12, 11.8.8, and 12.3.2.

Affected products

How to fix

Upgrade to a fixed version: MariaDB 10.6.27, 10.11.18, 11.4.12, 11.8.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-48165 or the next vulnerability affects your stack