What’s Vulnerable › Vulnerabilities
CVE-2026-48172: LiteSpeed cPanel Plugin Privilege Escalation Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-05-26
- EPSS: 17.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-21 · updated 2026-10-07
- Weakness: CWE-266
Description
LiteSpeed User-End cPanel Plugin before 2.4.5 allows privilege escalation (possibly to root), as exploited in the wild in May 2026. Detection is best done via a command line of grep -rE "cpanel_jsonapi_func=redisAble" /var/cpanel/logs /usr/local/cpanel/logs/ 2>/dev/null in Bash. If you get no output, you have not been hit with exploitation of the vulnerability. If there is output, we recommend you examine the IP addresses in the list, determine if they are valid IP addresses, and if not, block them. To determine damage done, examine the system logs for use by the detected IP addresses. The issue is related to mishandling of Redis enable/disable features. The recommended minimum version is 2.4.7.
Affected products
- litespeedtech Litespeed Cpanel Plugin: before 2.4.7 — fixed in 2.4.7
- litespeedtech Litespeed Whm Plugin: before 5.3.1.0 — fixed in 5.3.1.0
How to fix
Upgrade to a fixed version: litespeedtech Litespeed Cpanel Plugin 2.4.7; litespeedtech Litespeed Whm Plugin 5.3.1.0. Check the vendor advisory for mitigations.
References
- https://blog.litespeedtech.com/2026/05/21/security-update-for-litespeed-cpanel-plugin/
- https://www.litespeedtech.com/products/litespeed-web-server/control-panel-support/cpanel
- https://www.litespeedtech.com/products/litespeed-web-server/control-panel-support/release-log
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-48172
Get alerted when CVE-2026-48172 or the next vulnerability affects your stack