What’s Vulnerable › Vulnerabilities
CVE-2026-48207: Apache Fory: PyFory ReduceSerializer Incomplete Policy Enforcement
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-21 · updated 2026-07-23
- Weakness: CWE-502
Description
Deserialization of untrusted data in Apache Fory PyFory. PyFory's ReduceSerializer could bypass documented DeserializationPolicy validation hooks during reduce-state restoration and global-name resolution. An application is vulnerable if it deserializes attacker-controlled data using PyFory Python-native mode with strict mode disabled and relies on DeserializationPolicy to restrict unsafe classes, functions, or module attributes. This issue affects Apache Fory: from before 1.0.0. Mitigation: Users of Apache Fory are recommended to upgrade to version 1.0.0 or later, which enforces DeserializationPolicy validation for the affected ReduceSerializer paths and thus fixes this issue.
Affected products
- Apache Software Foundation Apache Fory: from 0.13.0 before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Fory 1.0.0. Check the vendor advisory for mitigations.
References
- https://fory.apache.org/security/#cve-2026-48207-pyfory-reduceserializer-deserializationpolicy-bypass
- http://www.openwall.com/lists/oss-security/2026/05/21/10
Get alerted when CVE-2026-48207 or the next vulnerability affects your stack