What’s Vulnerable › Vulnerabilities
CVE-2026-48371: Adobe Commerce | Cross-site Scripting (Stored XSS) (CWE-79)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-08-28
- Weakness: CWE-79
Description
Adobe Commerce is affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a low-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim's browser when they browse to the page containing the vulnerable field. Scope is changed.
Affected products
- Adobe Commerce: 2.4.4, 2.4.4-p1, 2.4.4-p10, 2.4.4-p11, 2.4.4-p12, 2.4.4-p13 (+70)
- Adobe Commerce: 1.3.3, 1.3.3-p1, 1.3.3-p10, 1.3.3-p11, 1.3.3-p12, 1.3.3-p13 (+49)
- Adobe I/O Events: from 1.6.0 before 1.21.0 — fixed in 1.21.0
- Adobe Magento: 2.4.6, 2.4.6-p1, 2.4.6-p10, 2.4.6-p11, 2.4.6-p12, 2.4.6-p13 (+33)
- Adobe Commerce Events: through 1.20.0
- Adobe Commerce: through 2.4.9, 2.4.8-p5, 2.4.7-p10, 2.4.6-p15, 2.4.5-p17, 2.4.4-p18
- Adobe Commerce: through 1.5.3, 1.5.2-p5, 1.4.2-p10, 1.3.4-p17, 1.3.3-p18
- Adobe Magento Open Source: through 2.4.9, 2.4.8-p5, 2.4.7-p10, 2.4.6-p15
How to fix
Upgrade to a fixed version: Adobe I/O Events 1.21.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-48371 or the next vulnerability affects your stack